abb plc pm572 and ethernet module cm572 confıguration error. Connectıon through tk503 cable.

I have 1 PM572(TK503 CABLE CONNECTION) plc, 3 DO562, 3 DI562 modules, 1 CM579 PNIO communication module. The problem I face here, after confıgurıng my project in automation builder v1.2 through CoDeSys when I try to login I get error confıguration problem. I have tried every thing like, changing comunication module and cpu respectively but all in vane. I also formated my pc and again install automation builder but didn't get any positive results.
Did anybody face the same problem or have any solution/advice?

Associated Apps

ABB GSD Files (1.0)  Download

Communication Module Firmware Update Variants (1.0)  Download

AC500 Codesys Volumes Lib (1.0)  Download


Add New Comment


Faris   

asked 3 months ago
Closed



Answers

0

Hi Faris

your problem may have originated from multiple causes ...first of all make sure that your Automation Buider session have correct define the communication parameters.



Do not forget that your domain / subnetmask and IP adress of PLC must be the same of PC - network where you should activate the project.

In the attached image one simple configuration in AB. The only difference I used in my project PM573 ETH.

For serial communication with TK cable, you must use com_param settings as the other attached file

Of course in Codesys the parameter are the same.

Hope this help you

 CM579.PNG

 com_param.PNG

Flavio Mussolin   

answered 3 months ago


 


By Faris on 1/10/2018 | Like (0) | Report

Hi Mussolin,
Firstly thanx for your reply.
I checked the points you stated in your answer in my project. They all meet the conditions.


By Faris on 1/10/2018 | Like (0) | Report

But still having the configuration error during login.


By Faris on 1/10/2018 | Like (0) | Report

Actually when removing CM579 PNIO İ am able to login without errors. But when İ attach CM579 PNİO i again get that error.


By Flavio Mussolin on 1/10/2018 | Like (0) | Report

Ok Faris,
one possible cause is the FW version of your CPU vs the CM579 interface...you not have one most recently CPU to try? For example one PM573-583-590?

What version of automation builder are you using?
Have you see the FW version of CPU?
If you are using AB 2.03 you can update the FW of the CPU directly by software


By Faris on 1/10/2018 | Like (0) | Report

Unfortunately i dont have any other cpu.
İs it possible to update fw using automation builder v1.2?


By Faris on 1/10/2018 | Like (0) | Report

No i dont know the fw version of my cpu and cm579 pnio


By Flavio Mussolin on 1/10/2018 | Like (0) | Report

You can update cpu using SD card...at the follow link more update files , do attention to the instruction for the update. Select the appropriate files and the version that you want to update.

http://www.abb.it/abblibrary/DownloadCenter/#&&/w...


By Flavio Mussolin on 1/10/2018 | Like (0) | Report

By automation Buider you can read the FW version of the CM - PM unit


By Faris on 1/17/2018 | Like (0) | Report

Hi Mussolin, İ did the firmware updation of pm and cm. But the problem occurs again. Updation process was like this, export files from plc through automation builder and write the same files to the plc through codesys. A friend told me to do like this. As i have automation builder v1.2.
İs the updation process wrong?


By Flavio Mussolin on 1/17/2018 | Like (0) | Report

Hi Faris
Have you verified that the TB521 in your project is Eth model ?
The update process is automatically written on the SD card as per instructions that you find on the page of updates that I wrote in a previous message. You must insert the updated SD card into the slot with the CPU turned off and then power up the CPU. The process of reading the update by the CPU is automatic, because at power up the CPU reads the instructions from the SD card.
Only with Automation Builder 2.0 can the update be done directly from AB.
If when you remove the CM579 you can make your PLC work, you have to consider that the 579 could be broken. To understand any other possible causes of this malfunction, I should be able to see your components, but this is not possible.
I suggest you try to change either the cpu or the CM579, because I not have at the moment other suggestions to give you


Add New Comment


0

Plc configuration error picture and plc project picture are attached.

 IMG_20180110_171357.jpg

 1515593764504-179654.jpg

Faris   

answered 3 months ago


 


Add New Comment



Get weekly AKS updates


Partner Exclusive Webinars

 

> – Login to the partner portal to register



Points Redemption Program - Redeem your points for ABB training, Bluetooth speakers and mugs. Terms and conditions >


Earn points when you refer a friend
AKS Referral Program is "Live" - Learn more



AKS Experts


avatar
Ask Govindaraj   

Rank: 9

Working in ABB India Operation Center. Have Project engineering and commissioning experience in ABB 800xA, Freelance, AC500.


avatar
Ask MMM   

Rank: 5

ABB PA CT Technical Support


avatar
Ask kstoilov   

Rank: 11

Control System Engineer: 800xA, Compact 800, AC500, AC31-50, Advant Master, Simatic, AC&DC Drives 11 years worked for ABB - Control Systems


avatar
Ask Flavio Mussolin   

Rank: 4

ABB AVP, Senior Electronic and Automation Engineer with over 30 years of experience in the field of process automation automotive, pharmaceutical, hollow glass, steel and rolling.


avatar
Ask Harsha.D   

Rank: 7

Tech.Support,software and commisioning engineer with Proficient knowledge in 800xA and its products, RNRP,Networking in general.


avatar
Ask Dieter Henkel   

Rank: 19


avatar
Ask Sumit Gargav   

Rank: 3

I have worked with Freelance in majority, with 800xA FD and Melody system partly. Also had opportunity to work with Protocols - HART,Profibus,FF & Modbus.


avatar
Ask Rob Lyon   

Rank: 2

info@lymac.co.nz I'm an independent DCS software and commissioning engineer with extensive experience in 800xA and other ABB products. I've worked in almost every corner of the world and still haven't seen it all.


avatar
Ask Stefan Stromqvist   

Rank: 1

I joined ABB in the year of 1994 and has since 1999 been working as a Service & Support Engineer at BU Control Technologies in Västerås, Sweden. My areas of expertise are: 800xA Base, 800xA for Advant Master, Information Management, operating systems, RNRP and Ethernet comms/networking in general.


avatar
Ask WvanWees   

Rank: 6

I'm a senior service engineer working for ABB in The Netherlands.


avatar
Ask nikismith   

Rank: 255

I have been a part of the Recording & Control Factory team for 17 years in total, having spent a number of years as a repairs technician withi the manufacturing department, but being in my current role for 9 years now.


avatar
Ask Ronny Lindström   

Rank: 16

ABB Service Engineer