AC500 Redundancy Problem

Hello Evryone,

In My System i am using PM590 in redundant configuration.

during shutdown activity I faced following problem 2-3 days ago. can anybudy guid me how to reslve this?

Plant is running OK in. after some modification in logic i download first in CPU A. and it will run OK. now after downloading in CPU B after 3-4 second it will go offline and show Communication Error in Codesys. after that i cant make it online from PC.

than i press Stop Buton from CPU and try to make it Online and it will sucssess. than what i observed from task manager all task i set it shows Error. and i cant make it in Run mode from Codesys as well as from key board. after cold reset plc from codesys again i download program in CPU B. same problem repeat 2-3 times.

after this, I completly reset PLC. set IP address. and agin download program. But same problem again.

Than for testing i removed eth. link from CPU A to CPU B. than i reset plc and make it run. it will run fine.

but when i connect link between both PLC. again same problem happen.

then i power off both CPU and power on again than i resolve problem.

So what is reason because of this i faced above problem. can anybody help me??


Add New Comment


MaheshDevaliya   

asked 4 months ago
Closed



Best Answer

1

Hi,

I too am facing a similar problem at site with the PM590 redundant configuration, with PM597s as communication coupler modules.We are using AB 1.2.4.

From my earlier experiences and from that gained from trying to solve a similar existing problem, i will try to provide some troubleshooting tips to those who are facing similar issues, point wise.

Q) Plant is running OK in. after some modification in logic i download first in CPU A. and it will run OK. now after downloading in CPU B after 3-4 second it will go offline and show Communication Error in Codesys. after that i cant make it online from PC.

A)

I am assuming you are using CM597 for OPC server connection and for going online and onboard ETH ports for HA data synchronization.

* If there is firmware mismatch between the automation builder software and that loaded on the CPU/CM597, it is advisable to update to the latest firmware in AB software.

*Please make sure that the CM597 is not running out of sockets.If you have reserved too many ports for MODBUS communication, there is a chance that Codesys is unable to establish a connection with the CPU.

*After making any changes to the application, make sure you do a clean all, followed by Rebuild all, before you download to the CPU.

*Try to manually stop the codesys gateway server from notification icon tray and then attempt to download to PLC B.

*If possible, download to the backup CPU first and then to the Primary CPU.Observe whether there is any improvement.


Q)....than i press Stop Buton from CPU and try to make it Online and it will sucssess

A)

*Make sure that when performing a reset from the CPU softkeys, during the post reset initialisation phase, select MODE 00 (NODE 00 as on display) and not the default NODE 01.

Q) ....than what i observed from task manager all task i set it shows Error. and i cant make it in Run mode from Codesys as well as from key board. after cold reset plc from codesys again i download program in CPU B. same problem repeat 2-3 times.

A)

*Verify whether your HA task time is not less than the CS31 bus cycle time. If need be, provide a cycle time of 50ms to start with.

*A closer look at your task configuration is needed for any further trouble shooting.If possible provide a screen shot.

Q)...

after this, I completly reset PLC. set IP address. and agin download program. But same problem again.

Than for testing i removed eth. link from CPU A to CPU B. than i reset plc and make it run. it will run fine.

but when i connect link between both PLC. again same problem happen.

A)

* Ensure that the cable for linking the two PLCs is a CROSSOVER cable and that the terminations to the RJ45 connectors are proper and secured.

*Verify whether UDP data exchange protocol is added in AB, to the onboard ETH ports intended for HA synchronization

Kindly utilize the above tips, to further troubleshoot your system.Kindly revert back with your observations and any other solutions known to you. My company is planning to escalate this issue to abb, as we suspect there is some issue with the CM597s and their firmware, when used in a network configuration demanding redundancy in ethernet communication and support for RSTP. At present we have temporarily replaced CM597s with our older CM577s.The CM577s seem to work better in a redundant setup.

I request other forum members to also contribute to the solution ,as the reliabilty of the communication modules and indirectly the ac500 solution are being questioned by our client.Our problem is compounded by the use of three CM574 module pairs, for MODBUS communication.The CM574s stop working on 5/10 occassions ,when a modified program is downloaded or when a switchover occurs.

rahilmohammed   

answered 4 months ago


 


By MaheshDevaliya on 6/11/2017 | Like (0) | Report

Hello,

Thankyou verymuch for support.

I checked each point you mention in your answer. I am unis right now CM577 for Communication with PC. and also use CM574 for IO Communication on CS31 Protocol. firmware of all modules are OK.

Problem is rectified after restart both CPU at same time. but in future may be this problem rise.

as plant in running condition so now i cant do anything upto next shutdown cycle.

if i found any solution than i will share it with you.

once again thanks...


By rahilmohammed on 6/12/2017 | Like (0) | Report

Hi,
There is a very high chance that you will face the same issue when you will download a modified application.Our site is in the final sstage of commissioning.Hence,we have some time to check all possible trouble shooting steps known to us.During testing,we have repeatedly faced same issues with CM597.With CM577s the problems are somewhat less.


Add New Comment


Answers

1

Hi,

I too am facing a similar problem at site with the PM590 redundant configuration, with PM597s as communication coupler modules.We are using AB 1.2.4.

From my earlier experiences and from that gained from trying to solve a similar existing problem, i will try to provide some troubleshooting tips to those who are facing similar issues, point wise.

Q) Plant is running OK in. after some modification in logic i download first in CPU A. and it will run OK. now after downloading in CPU B after 3-4 second it will go offline and show Communication Error in Codesys. after that i cant make it online from PC.

A)

I am assuming you are using CM597 for OPC server connection and for going online and onboard ETH ports for HA data synchronization.

* If there is firmware mismatch between the automation builder software and that loaded on the CPU/CM597, it is advisable to update to the latest firmware in AB software.

*Please make sure that the CM597 is not running out of sockets.If you have reserved too many ports for MODBUS communication, there is a chance that Codesys is unable to establish a connection with the CPU.

*After making any changes to the application, make sure you do a clean all, followed by Rebuild all, before you download to the CPU.

*Try to manually stop the codesys gateway server from notification icon tray and then attempt to download to PLC B.

*If possible, download to the backup CPU first and then to the Primary CPU.Observe whether there is any improvement.


Q)....than i press Stop Buton from CPU and try to make it Online and it will sucssess

A)

*Make sure that when performing a reset from the CPU softkeys, during the post reset initialisation phase, select MODE 00 (NODE 00 as on display) and not the default NODE 01.

Q) ....than what i observed from task manager all task i set it shows Error. and i cant make it in Run mode from Codesys as well as from key board. after cold reset plc from codesys again i download program in CPU B. same problem repeat 2-3 times.

A)

*Verify whether your HA task time is not less than the CS31 bus cycle time. If need be, provide a cycle time of 50ms to start with.

*A closer look at your task configuration is needed for any further trouble shooting.If possible provide a screen shot.

Q)...

after this, I completly reset PLC. set IP address. and agin download program. But same problem again.

Than for testing i removed eth. link from CPU A to CPU B. than i reset plc and make it run. it will run fine.

but when i connect link between both PLC. again same problem happen.

A)

* Ensure that the cable for linking the two PLCs is a CROSSOVER cable and that the terminations to the RJ45 connectors are proper and secured.

*Verify whether UDP data exchange protocol is added in AB, to the onboard ETH ports intended for HA synchronization

Kindly utilize the above tips, to further troubleshoot your system.Kindly revert back with your observations and any other solutions known to you. My company is planning to escalate this issue to abb, as we suspect there is some issue with the CM597s and their firmware, when used in a network configuration demanding redundancy in ethernet communication and support for RSTP. At present we have temporarily replaced CM597s with our older CM577s.The CM577s seem to work better in a redundant setup.

I request other forum members to also contribute to the solution ,as the reliabilty of the communication modules and indirectly the ac500 solution are being questioned by our client.Our problem is compounded by the use of three CM574 module pairs, for MODBUS communication.The CM574s stop working on 5/10 occassions ,when a modified program is downloaded or when a switchover occurs.

rahilmohammed   

answered 4 months ago


 


By MaheshDevaliya on 6/11/2017 | Like (0) | Report

Hello,

Thankyou verymuch for support.

I checked each point you mention in your answer. I am unis right now CM577 for Communication with PC. and also use CM574 for IO Communication on CS31 Protocol. firmware of all modules are OK.

Problem is rectified after restart both CPU at same time. but in future may be this problem rise.

as plant in running condition so now i cant do anything upto next shutdown cycle.

if i found any solution than i will share it with you.

once again thanks...


By rahilmohammed on 6/12/2017 | Like (0) | Report

Hi,
There is a very high chance that you will face the same issue when you will download a modified application.Our site is in the final sstage of commissioning.Hence,we have some time to check all possible trouble shooting steps known to us.During testing,we have repeatedly faced same issues with CM597.With CM577s the problems are somewhat less.


Add New Comment


0

Update:

Under PM5xx-ETH Parameters Tab,Select value “Ethernet Handling Prioritized” for Task compatibility mode.

As per ABB technical team,doing this will improve the behaviour of Ethernet communication between Codesys and PLC after a logout,post download/online change of a large project to the PLC.

Also, each Task in Task configuration must be assigned a unique priority number.

Regards

Rahil

 20170730_112929.jpg

rahilmohammed   

answered 2 months ago


 


Add New Comment



Get weekly AKS updates


Partner Exclusive Webinars

 

> – Login to the partner portal to register



Points Redemption Program - Redeem your points for ABB training, Bluetooth speakers and mugs. Terms and conditions >


Earn points when you refer a friend
AKS Referral Program is "Live" - Learn more



AKS Experts


avatar
Ask Harsha.D   

Rank: 6

Tech.Support,software and commisioning engineer with Proficient knowledge in 800xA and its products, RNRP,Networking in general.


avatar
Ask MMM   

Rank: 5

ABB PA CT Technical Support


avatar
Ask Dieter Henkel   

Rank: 23


avatar
Ask Flavio Mussolin   

Rank: 4

ABB AVP, Senior Electronic and Automation Engineer with over 30 years of experience in the field of process automation automotive, pharmaceutical, hollow glass, steel and rolling.


avatar
Ask nikismith   

Rank: 261

I have been a part of the Recording & Control Factory team for 17 years in total, having spent a number of years as a repairs technician withi the manufacturing department, but being in my current role for 9 years now.


avatar
Ask Rob Lyon   

Rank: 3

info@lymac.co.nz I'm an independent DCS software and commissioning engineer with extensive experience in 800xA and other ABB products. I've worked in almost every corner of the world and still haven't seen it all.


avatar
Ask Stefan Stromqvist   

Rank: 1

I joined ABB in the year of 1994 and has since 1999 been working as a Service & Support Engineer at BU Control Technologies in Västerås, Sweden. My areas of expertise are: 800xA Base, 800xA for Advant Master, Information Management, operating systems, RNRP and Ethernet comms/networking in general.


avatar
Ask Govindaraj   

Rank: 10

Working in ABB India Operation Center. Have Project engineering and commissioning experience in ABB 800xA, Freelance, AC500.


avatar
Ask kstoilov   

Rank: 16

Control System Engineer: 800xA, Compact 800, AC500, AC31-50, Advant Master, Simatic, AC&DC Drives 11 years worked for ABB - Control Systems


avatar
Ask Sumit Gargav   

Rank: 2

I have worked with Freelance in majority, with 800xA FD and Melody system partly. Also had opportunity to work with Protocols - HART,Profibus,FF & Modbus.